CentOS 5.5 に、Firefox 4

Firefox 4 が公開されたので早速インストールしてみた。
が、以下のエラーメッセージが表示され、起動しない。

% ./firefox-bin: /usr/lib/libstdc++.so.6: version `GLIBCXX_3.4.9′ not found (required by /opt/firefox4.0/libxul.so)

libstdc++.so.6に、”GLIBCXX_3.4.9″が見つからないと言われた。
System内に入っている libstdc++.so.6 を調べてみると、avg8 で使用している libstdc++.so.6 に、GLIBCXX_3.4.9 が入っている事が分かった。

LD_LIBRARY_PATH=/opt/avg/avg8/lib/:$LD_LIBRARY_PATH

によりライブラリパスを通すと、Firefox 4は正常に起動した。
が、今度は、プラグインから同様なエラーを出力

/opt/firefox4.0/plugin-container: /usr/lib/libstdc++.so.6: version `GLIBCXX_3.4.9′ not found (required by /opt/firefox4.0/libxul.so)

パスが通っているのに…?
それに、10数秒 Firefox が固まってしまった。

/usr/lib 内の libstdc++.so.6 を確認してみると

… libstdc++.so.6 -> libstdc++.so.6.0.8
… libstdc++.so.6.0.8

となっているので、

# cd /usr/lib
# cp /opt/avg/avg8/lib/libstdc++.so.6 libstdc++.so.6.0.9
# rm libstdc++.so.6
# ln -s ./libstdc++.so.6.0.9 libstdc++.so.6
# ls
… libstdc++.so.6 -> libstdc++.so.6.0.9
… libstdc++.so.6.0.8
… libstdc++.so.6.0.9

のように、やむなく、libstdc++.so.6 を入れ替えて対応。
プラグインからも、また、固まりもせず、無事起動。

広告